Debian problém – dpkg dependtry

Tak si inštalujem balíček a aha ho koťuhu. Dpkg mi začalo nepekne nadávať v jazyku C:

dpkg: ../../src/packages.c:221: process_queue: Assertion `dependtry <= 4' failed.

Ej veru. Nejakú chvíľku som sa s problémom trápil. Skúšal som ručne odstrániť balíky, potom ich zase pridať. Presne tak ako to tvrdilo veľa užitočných príspevkov vo fórách. No a hádajte ako to dopadlo? Nepomohlo to.

Pozrel som sa teda na archív balíčkov. Vravím si, skúsim upgrade dpkg.

wget http://ftp.cz.debian.org/debian/pool/main/d/dpkg/dpkg_1.15.4.1_i386.deb
dpkg -i dpkg_1.15.4.1_i386.deb
dpkg --configure -a

Zabralo. Pravdepodobne to bola chyba v implementácii dpkg.

No votes yet.
Please wait...
Voting is currently disabled, data maintenance in progress.

November 6, 2009 at 5:39 pm - Software engineering, Uncategorized (Tags: , , , ).

  • Preklady

  • Odkazy

  • Twitter

    Follow @jurajmichalek on twitter.

  • Štítky

  • Rubriky

  • Komentáre